Library / LOLBin

scriptrunner.exe

· Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 6

OriginalFilename

  • ScriptRunner.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\scriptrunner.exe'
    - OriginalFileName: 'ScriptRunner.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ScriptRunner.exe7x8610.0.14393.7330 → 10.0.26100.1882Win10 1607 → Win11 24H2 (6)Host scan, Winbindex✓ 1

InternalName: ScriptRunner.exe · Product: Microsoft (R) Windows (R) Operating System

All 7 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fb5d18052e35…10.0.14393.7330x86ScriptRunner.exeWin10 1607Signed (Overlay)Winbindex
49b1bc9a73d3…10.0.26100.1x86ScriptRunner.exeWin11 24H2Signed (Overlay)Winbindex
eaa98074d7cc…10.0.22621.3085x86ScriptRunner.exeWin11 22H2Signed (Overlay)Winbindex
93819fddbc03…10.0.22621.2215x86ScriptRunner.exeWin11 22H2, Win11 23H2Signed (Overlay)Winbindex
56eda99d42ef…10.0.15063.0x86ScriptRunner.exeWin10 1703Signed (Overlay)Winbindex
d115f06738d2…10.0.16299.15x86ScriptRunner.exeWin10 1709Signed (Overlay)Winbindex
883784cb5ad1…10.0.26100.1882x86ScriptRunner.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.