Library / Windows

sdiagnhost.exe

Scripted Diagnostics Native Host · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • sdiagnhost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\sdiagnhost.exe'
    - OriginalFileName: 'sdiagnhost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
sdiagnhost.exe16x64, x8610.0.10240.19387 → 10.0.28000.1896Win10 1507 → Win11 26H1 (11)Host scan, Winbindex✓ 2

InternalName: sdiagnhost.exe · Product: Microsoft® Windows® Operating System

All 16 parsed builds · 20 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
86fdc89c1aa4…10.0.28000.1896x86sdiagnhost.exeWin11 26H1UnsignedWinbindex
339a23e30838…10.0.28000.1896x64sdiagnhost.exeWin11 26H1UnsignedWinbindex
a6e9c3f8a8bc…10.0.26100.8115x86sdiagnhost.exeWin11 24H2UnsignedHost scan, Winbindex✓
29a7f20c590f…10.0.26100.8115x64sdiagnhost.exeWin11 24H2UnsignedHost scan, Winbindex✓
eb5954d56206…10.0.17763.3287x64sdiagnhost.exeWin10 1809UnsignedWinbindex
80f2327eae32…10.0.14393.5291x64sdiagnhost.exeWin10 1607UnsignedWinbindex
249a8f39c105…10.0.14393.5291x86sdiagnhost.exeWin10 1607UnsignedWinbindex
e0305009bc75…10.0.10240.19387x64sdiagnhost.exeWin10 1507UnsignedWinbindex
900c2ecf79ea…10.0.10240.19387x86sdiagnhost.exeWin10 1507UnsignedWinbindex
1c7903d2ea02…10.0.26100.1150x64sdiagnhost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
373338548148…10.0.26100.1x86sdiagnhost.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
e5ec6b5b20a1…10.0.19041.2546x64sdiagnhost.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
9478dd126433…10.0.19041.1889x86sdiagnhost.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
018a17643817…10.0.16299.15x64sdiagnhost.exeWin10 1709UnsignedWinbindex
a04b1c9a87aa…10.0.10586.0x64sdiagnhost.exeWin10 1511UnsignedWinbindex
6d523d925ef9…10.0.10586.0x86sdiagnhost.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.