Library / Windows

securityhealthhost.exe

Windows Security Health Host · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • SecurityHealthHost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\securityhealthhost.exe'
    - OriginalFileName: 'SecurityHealthHost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SecurityHealthHost.exe2x6410.0.26100.9549 → 10.0.29680.1000Host scan✓ 1

InternalName: Windows Security Health Host · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a6455eade951…10.0.29680.1000x64SecurityHealthHost.exeHost scan
4f195cf33ac4…10.0.26100.9549x64SecurityHealthHost.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.