Library / Windows

servicemodelreg.exe

WCF Generic Command for Vista Setup · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • ServiceModelReg.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\servicemodelreg.exe'
    - OriginalFileName: 'ServiceModelReg.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ServiceModelReg.exe2x64, x864.8.10001.0Host scan✓ 2

InternalName: ServiceModelReg.exe · Product: Microsoft® .NET Framework

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
eb61e00b0ddc…4.8.10001.0x64ServiceModelReg.exeHost scan✓
7bcf1b26ae8b…4.8.10001.0x86ServiceModelReg.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.