Library / Windows

setspn.exe

Query or reset the computer's SPN attribute · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • setspn.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\setspn.exe'
    - OriginalFileName: 'setspn.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
setspn.exe6x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Host scan, Winbindex✓ 1

InternalName: setspn · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a986b07d96be…10.0.28000.1896x64setspn.exeWin11 26H1Winbindex
517175a4d5d8…10.0.28000.1896x86setspn.exeWin11 26H1Winbindex
52619a89e3b5…10.0.26100.1x64setspn.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
909c2ddf06cf…10.0.14393.0x64setspn.exeWin10 1607UnsignedWinbindex
0bc8830faf6b…10.0.10586.0x64setspn.exeWin10 1511UnsignedWinbindex
23bb3fa346bf…10.0.10240.16384x64setspn.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.