Library / LOLBin

setupugc.exe

Setup Unattend Generic Command Processor · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • SETUPUGC.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\setupugc.exe'
    - OriginalFileName: 'SETUPUGC.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SETUPUGC.EXE20x64, x8610.0.10240.17202 → 10.0.28000.3231Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 2

InternalName: SetupUGC.exe · Product: Microsoft® Windows® Operating System

All 20 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0163dbc32fa6…10.0.28000.3231x64SETUPUGC.EXEWin11 26H1Winbindex
cca9384c3a4f…10.0.26100.9711x86SETUPUGC.EXEWin11 24H2UnsignedHost scan, Winbindex✓
676bc0e5a22e…10.0.26100.9711x64SETUPUGC.EXEWin11 24H2UnsignedHost scan, Winbindex✓
0c20322a2009…10.0.17763.1518x64SETUPUGC.EXEWin10 1809UnsignedWinbindex
72bd5df944a8…10.0.14393.7330x64SETUPUGC.EXEWin10 1607UnsignedWinbindex
39ebd78249ab…10.0.14393.7330x86SETUPUGC.EXEWin10 1607UnsignedWinbindex
908c10c20aa3…10.0.28000.3086x86SETUPUGC.EXEWin11 26H1Winbindex
f1333505a65f…10.0.10240.17202x64SETUPUGC.EXEWin10 1507UnsignedWinbindex
03a3c8db6721…10.0.10240.17202x86SETUPUGC.EXEWin10 1507UnsignedWinbindex
8f4bc88f1576…10.0.26100.5074x64SETUPUGC.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
41f2d6cab264…10.0.26100.5074x86SETUPUGC.EXEWin11 24H2, Win11 25H2UnsignedWinbindex
de6fd33ba98d…10.0.19041.746x86SETUPUGC.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
aae6db852b70…10.0.19041.746x64SETUPUGC.EXEWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
ffb812529d0a…10.0.17134.1792x86SETUPUGC.EXEWin10 1803UnsignedWinbindex
3fdbcb1f24fb…10.0.17134.1792x64SETUPUGC.EXEWin10 1803UnsignedWinbindex
1307030533eb…10.0.15063.1155x86SETUPUGC.EXEWin10 1703UnsignedWinbindex
a4a3551da854…10.0.10586.839x86SETUPUGC.EXEWin10 1511UnsignedWinbindex
64dc6b618d05…10.0.10586.839x64SETUPUGC.EXEWin10 1511UnsignedWinbindex
6b62023fd066…10.0.16299.15x86SETUPUGC.EXEWin10 1709UnsignedWinbindex
4b111fbafef4…10.0.16299.15x64SETUPUGC.EXEWin10 1709UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.