Library / Windows

setx.exe

Setx - Sets environment variables · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • setx.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\setx.exe'
    - OriginalFileName: 'setx.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
setx.exe2x64, x8610.0.26100.1Host scan✓ 2

InternalName: setx.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f4bec9d2f7e6…10.0.26100.1x64setx.exeHost scan✓
8d46eb608912…10.0.26100.1x86setx.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.