Library / Windows

sfc.exe

System Integrity Check and Repair · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • sfc.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\sfc.exe'
    - OriginalFileName: 'sfc.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
sfc.exe2x64, x8610.0.26100.9549Host scan✓ 2

InternalName: sfc.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
408067cad0fd…10.0.26100.9549x86sfc.exeHost scan✓
2cf11d47fb66…10.0.26100.9549x64sfc.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.