Library / LOLBin

sftp.exe

LOLBinWindowsParsedLOLBASSigma refs: 1

OriginalFilename

None. No observed build carries an OriginalFilename, so sensors log -.

No OriginalFilename

Gotchas

  • No OriginalFilename in any observed build, so Sysmon logs - and OriginalFileName rules can't match it. Anchor on the image path, hash or signer instead.

Query snippets

# No OriginalFilename in any observed build: match on the image instead
logsource:
  category: process_creation
  product: windows
detection:
  selection:
    Image|endswith: '\sftp.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
none8x647.6.0.0 → 9.5.6.4Win10 1803 → Win11 26H1 (15)Host scan, Winbindex
All 8 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d3f093040163…9.5.6.4x64noneWin11 24H2, Win11 26H1UnsignedHost scan, Winbindex
d0790736a201…9.5.5.3x64noneWin10 1809 … Win11 23H2 (3)UnsignedWinbindex
62ea766d92eb…9.5.5.1x64noneWin10 1809 … Win11 25H2 (4)Signed (Catalog file)Winbindex
7f9499c49e53…9.5.4.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
9974b45844c8…9.5.2.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
a354eb6416ab…8.1.0.1x64noneWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
7651a9e5721c…7.7.2.1x64noneWin10 1809 … Win10 21H1 (6)Signed (Catalog file)Winbindex
d38299b410e6…7.6.0.0x64noneWin10 1803UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.