Library / LOLBin

shdocvw.dll

Shell Doc Object and Control Library · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • SHDOCVW.DLL

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\shdocvw.dll'
    - OriginalFileName: 'SHDOCVW.DLL'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SHDOCVW.DLL29x64, x8610.0.10240.20793 → 10.0.28000.3086Win10 1507 → Win11 26H1 (17)Winbindex

InternalName: SHDOCVW.DLL · Product: Microsoft® Windows® Operating System

All 29 parsed builds · 6 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
60804aff5e9c…10.0.28000.3086x86SHDOCVW.DLLWin11 26H1Winbindex
2c90930eda5e…10.0.28000.3086x64SHDOCVW.DLLWin11 26H1UnsignedWinbindex
e4af56610ec9…10.0.26100.9549x86SHDOCVW.DLLWin11 24H2UnsignedWinbindex
d32aaa6953cf…10.0.26100.9549x64SHDOCVW.DLLWin11 24H2UnsignedWinbindex
3c99557a8804…10.0.19041.7802x64SHDOCVW.DLLWin10 21H2UnsignedWinbindex
805f9391472e…10.0.17763.9376x86SHDOCVW.DLLWin10 1809Winbindex
7a8130867b1d…10.0.14393.9611x64SHDOCVW.DLLWin10 1607UnsignedWinbindex
609c0b052dd4…10.0.14393.9611x86SHDOCVW.DLLWin10 1607UnsignedWinbindex
06dd0ff7417d…10.0.17763.8880x64SHDOCVW.DLLWin10 1809Signed (Catalog file)Winbindex
642c9c5fab60…10.0.10240.20793x64SHDOCVW.DLLWin10 1507UnsignedWinbindex
45befab32c32…10.0.10240.20793x86SHDOCVW.DLLWin10 1507UnsignedWinbindex
8f887754d79f…10.0.26100.5074x64SHDOCVW.DLLWin11 24H2, Win11 25H2UnsignedWinbindex
4e3a14a6dd62…10.0.26100.5074x86SHDOCVW.DLLWin11 24H2, Win11 25H2UnsignedWinbindex
705752514b72…10.0.22000.1696x86SHDOCVW.DLLWin11 21H2UnsignedWinbindex
6786782682b5…10.0.22000.1696x64SHDOCVW.DLLWin11 21H2UnsignedWinbindex
f37bbd26a1df…10.0.19041.2728x86SHDOCVW.DLLWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
a690ac75d7da…10.0.19041.2728x64SHDOCVW.DLLWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
c2514c508bb6…10.0.19041.746x64SHDOCVW.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
657f5f85ee9e…10.0.19041.746x86SHDOCVW.DLLWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
dfcd12abe283…10.0.17134.1967x64SHDOCVW.DLLWin10 1803UnsignedWinbindex
49d514bf883d…10.0.17134.1967x86SHDOCVW.DLLWin10 1803UnsignedWinbindex
a689b926006e…10.0.15063.2614x64SHDOCVW.DLLWin10 1703UnsignedWinbindex
427c270d730f…10.0.15063.2614x86SHDOCVW.DLLWin10 1703UnsignedWinbindex
8486be25a5fe…10.0.18362.1316x64SHDOCVW.DLLWin10 1909UnsignedWinbindex
13611ceec231…10.0.18362.1316x86SHDOCVW.DLLWin10 1909UnsignedWinbindex
7b660de5f313…10.0.18362.997x64SHDOCVW.DLLWin10 1903UnsignedWinbindex
0da1f602a4f1…10.0.18362.997x86SHDOCVW.DLLWin10 1903UnsignedWinbindex
a468a877d38b…10.0.10586.1106x64SHDOCVW.DLLWin10 1511UnsignedWinbindex
1bc1708d73d8…10.0.10586.1106x86SHDOCVW.DLLWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.