Library / Windows

shellappruntime.exe

ShellAppRuntime · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • ShellAppRuntime.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\shellappruntime.exe'
    - OriginalFileName: 'ShellAppRuntime.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ShellAppRuntime.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: ShellAppRuntime · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1dedec5c93ec…10.0.26100.9711x64ShellAppRuntime.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.