Library / Sysinternals

shellrunas.exe

Run as different user · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • ShellRunas

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: shellrunas.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\shellrunas.exe'
    - OriginalFileName: 'ShellRunas'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
ShellRunas1x861.2.0.0Sysinternals✓ 1

InternalName: ShellRunas · Product: Sysinternals ShellRunAs

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d7d1ebac76fd…1.2.0.0x86ShellRunasSysinternals ShellRunAsSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.