Library / LOLBin

shimgvw.dll

Photo Gallery Viewer · Microsoft Corporation

LOLBinWindowsParsedLOLBAS

OriginalFilename

  • shimgvw.dll

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\shimgvw.dll'
    - OriginalFileName: 'shimgvw.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
shimgvw.dll12x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (6)Winbindex

InternalName: ShImgVw.dll · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 28 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f1cf358d5e53…10.0.28000.1896x86shimgvw.dllWin11 26H1Winbindex
a18b79fa606f…10.0.28000.1896x64shimgvw.dllWin11 26H1Winbindex
dce076d10958…10.0.26100.8115x86shimgvw.dllWin11 24H2UnsignedWinbindex
2f172a9d7af0…10.0.26100.8115x64shimgvw.dllWin11 24H2UnsignedWinbindex
b881373568b2…10.0.26100.1882x64shimgvw.dllWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
7d015f39f2ab…10.0.26100.1882x86shimgvw.dllWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
f7f63c9e9352…10.0.14393.0x86shimgvw.dllWin10 1607UnsignedWinbindex
7d1768117e39…10.0.14393.0x64shimgvw.dllWin10 1607UnsignedWinbindex
dc6e3f205649…10.0.10586.0x86shimgvw.dllWin10 1511UnsignedWinbindex
db41bf065745…10.0.10586.0x64shimgvw.dllWin10 1511UnsignedWinbindex
e9963da06052…10.0.10240.16384x64shimgvw.dllWin10 1507UnsignedWinbindex
14f9c5bbfdf5…10.0.10240.16384x86shimgvw.dllWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.