Library / Windows

shrpubw.exe

Share Creation Wizard · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • shrpubw.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\shrpubw.exe'
    - OriginalFileName: 'shrpubw.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
shrpubw.exe2x64, x8610.0.26100.4202Host scan✓ 2

InternalName: SHRWIZ · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
51f8d936fbda…10.0.26100.4202x86shrpubw.exeHost scan✓
1644cbc90c12…10.0.26100.4202x64shrpubw.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.