Library / LOLBin

sigverif.exe

File Signature Verification · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • sigverif.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\sigverif.exe'
    - OriginalFileName: 'sigverif.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
sigverif.exe6x6410.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 1

InternalName: sigverif.exe · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 13 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
fdd1f2e48b48…10.0.28000.1896x64sigverif.exeWin11 26H1Winbindex
699a11037818…10.0.26100.1x64sigverif.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
f8804f260fdf…10.0.22000.653x64sigverif.exeWin11 21H2UnsignedWinbindex
6008ae0fe2a2…10.0.14393.0x64sigverif.exeWin10 1607UnsignedWinbindex
9a184604bcac…10.0.10586.0x64sigverif.exeWin10 1511UnsignedWinbindex
8fe35a4cfb9f…10.0.10240.16384x64sigverif.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.