Library / Windows

sihost.exe

Shell Infrastructure Host · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 3

OriginalFilename

  • sihost.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\sihost.exe'
    - OriginalFileName: 'sihost.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
sihost.exe9x6410.0.10240.18818 → 10.0.28000.2804Win10 1507 → Win11 26H1 (13)Host scan, Winbindex✓ 1

InternalName: sihost.exe · Product: Microsoft® Windows® Operating System

All 9 parsed builds · 7 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
4ce5a16ef3df…10.0.28000.2804x64sihost.exeWin11 26H1UnsignedWinbindex
a0fe43136d77…10.0.26100.9278x64sihost.exeWin11 24H2UnsignedHost scan, Winbindex✓
c583457c0c35…10.0.17763.9376x64sihost.exeWin10 1809UnsignedWinbindex
b72fac49085f…10.0.14393.4169x64sihost.exeWin10 1607UnsignedWinbindex
10ae55095efb…10.0.26100.5074x64sihost.exeWin11 24H2, Win11 25H2UnsignedWinbindex
8284faa4a5c3…10.0.10240.18818x64sihost.exeWin10 1507UnsignedWinbindex
8ee21a0ba884…10.0.19041.746x64sihost.exeWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
2ff712d889f9…10.0.17134.1967x64sihost.exeWin10 1803UnsignedWinbindex
04b9882f5ea3…10.0.10586.0x64sihost.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.