Library / Windows

spaceagent.exe

Storage Spaces Settings · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • SpaceAgent.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\spaceagent.exe'
    - OriginalFileName: 'SpaceAgent.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SpaceAgent.exe1x6410.0.26100.9711Host scan✓ 1

InternalName: SpaceAgent · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
85b53be9b4f8…10.0.26100.9711x64SpaceAgent.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.