Library / Windows

speechruntime.exe

Speech Runtime Executable · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • SpeechRuntime.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\speechruntime.exe'
    - OriginalFileName: 'SpeechRuntime.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SpeechRuntime.exe20x6410.0.10240.18818 → 10.0.28000.2952Win10 1507 → Win11 26H1 (20)Host scan, Winbindex✓ 1

InternalName: Speech Runtime Executable · Product: Microsoft® Windows® Operating System

All 20 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a96fbfc047ea…10.0.28000.2952x64SpeechRuntime.exeWin11 26H1Winbindex
5994c6b11722…10.0.26100.9549x64SpeechRuntime.exeWin11 24H2UnsignedHost scan, Winbindex✓
40920599267f…10.0.19041.7725x64SpeechRuntime.exeWin10 21H2UnsignedWinbindex
5732b49c8f81…10.0.17763.9245x64SpeechRuntime.exeWin10 1809UnsignedWinbindex
7217a76e8497…10.0.14393.9507x64SpeechRuntime.exeWin10 1607UnsignedWinbindex
2f9e0bbc03b0…10.0.22621.6783x64SpeechRuntime.exeWin11 23H2UnsignedWinbindex
cb5e28c2b096…10.0.26100.5074x64SpeechRuntime.exeWin11 24H2, Win11 25H2UnsignedWinbindex
b9928eb0ad62…10.0.10240.18818x64SpeechRuntime.exeWin10 1507UnsignedWinbindex
94bae48fe9fb…10.0.22621.5331x64SpeechRuntime.exeWin11 22H2UnsignedWinbindex
57fafa4ba4f8…10.0.19041.5794x64SpeechRuntime.exeWin10 22H2UnsignedWinbindex
8dc913847be7…10.0.22000.51x64SpeechRuntime.exeWin11 21H2UnsignedWinbindex
c48dbfa78237…10.0.19041.1566x64SpeechRuntime.exeWin10 20H2 … Win10 22H2 (3)UnsignedWinbindex
64d1b059568c…10.0.18362.1593x64SpeechRuntime.exeWin10 1909UnsignedWinbindex
71f03c728a5a…10.0.19041.1266x64SpeechRuntime.exeWin10 2004 … Win10 21H2 (3)Signed (Catalog file)Winbindex
9535310b046e…10.0.19041.844x64SpeechRuntime.exeWin10 2004, Win10 21H1Signed (Catalog file)Winbindex
40d7f2d08c4e…10.0.17134.1967x64SpeechRuntime.exeWin10 1803UnsignedWinbindex
b76f84784cd9…10.0.18362.1016x64SpeechRuntime.exeWin10 1903UnsignedWinbindex
b685c9c83112…10.0.16299.2045x64SpeechRuntime.exeWin10 1709UnsignedWinbindex
f11743f828c8…10.0.15063.0x64SpeechRuntime.exeWin10 1703UnsignedWinbindex
5bb600f866ed…10.0.10586.420x64SpeechRuntime.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.