Library / Windows

sqlwriter.exe

SQL Server VSS Writer - 64 Bit · Microsoft Corporation

WindowsParsedSigma refs: 1

OriginalFilename

  • SQLWRITER.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\sqlwriter.exe'
    - OriginalFileName: 'SQLWRITER.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SQLWRITER.EXE1x642014.120.5214.6Win11 24H2Winbindex

InternalName: SQLWRITER · Product: Microsoft SQL Server

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6ffcc4fcc287…2014.120.5214.6x64SQLWRITER.EXEWin11 24H2Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.