Library / Windows

srtasks.exe

Microsoft® Windows System Protection background tasks. · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • srtasks.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\srtasks.exe'
    - OriginalFileName: 'srtasks.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
srtasks.exe11x6410.0.10240.18485 → 10.0.28000.2804Win10 1507 → Win11 26H1 (15)Host scan, Winbindex✓ 1

InternalName: srtasks · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 5 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
dfa686a10b46…10.0.28000.2804x64srtasks.exeWin11 26H1UnsignedWinbindex
93d9e83c15f4…10.0.26100.9549x64srtasks.exeWin11 24H2UnsignedHost scan, Winbindex✓
2baaf44abf41…10.0.17763.1039x64srtasks.exeWin10 1809UnsignedWinbindex
d033bacf5d07…10.0.14393.3503x64srtasks.exeWin10 1607UnsignedWinbindex
23c5d3da43b7…10.0.10240.18485x64srtasks.exeWin10 1507UnsignedWinbindex
693105226758…10.0.26100.1x64srtasks.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
40e27a9039a2…10.0.19041.84x64srtasks.exeWin10 2004 … Win10 22H2 (5)UnsignedWinbindex
318c7971aca6…10.0.17134.1304x64srtasks.exeWin10 1803UnsignedWinbindex
e4c3dd2aec47…10.0.15063.2283x64srtasks.exeWin10 1703UnsignedWinbindex
d8e65f912f81…10.0.16299.1685x64srtasks.exeWin10 1709UnsignedWinbindex
17dd14799c76…10.0.10586.0x64srtasks.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.