Library / LOLBin

ssh.exe

LOLBinWindowsParsedLOLBASSigma refs: 3

OriginalFilename

None. No observed build carries an OriginalFilename, so sensors log -.

No OriginalFilename

Gotchas

  • No OriginalFilename in any observed build, so Sysmon logs - and OriginalFileName rules can't match it. Anchor on the image path, hash or signer instead.

Query snippets

# No OriginalFilename in any observed build: match on the image instead
logsource:
  category: process_creation
  product: windows
detection:
  selection:
    Image|endswith: '\ssh.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
none8x647.6.0.0 → 9.5.6.4Win10 1803 → Win11 26H1 (15)Host scan, Winbindex
All 8 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
98d447730047…9.5.6.4x64noneWin11 24H2, Win11 26H1UnsignedHost scan, Winbindex
e588cc97309a…9.5.5.3x64noneWin10 1809 … Win11 23H2 (3)UnsignedWinbindex
8e1212d6b10b…9.5.5.1x64noneWin10 1809 … Win11 25H2 (4)Signed (Catalog file)Winbindex
c9a80ae8af88…9.5.4.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
b235aa64234d…9.5.2.1x64noneWin10 1809 … Win11 24H2 (6)UnsignedWinbindex
722bee41ccf5…8.1.0.1x64noneWin10 2004 … Win10 22H2 (4)UnsignedWinbindex
0c0e91427a4b…7.7.2.1x64noneWin10 1809 … Win10 21H1 (6)Signed (Catalog file)Winbindex
68cbd98ffea3…7.6.0.0x64noneWin10 1803UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.