Library / LOLBin

stordiag.exe

· Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 1

OriginalFilename

  • stordiag.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\stordiag.exe'
    - OriginalFileName: 'stordiag.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
stordiag.exe5x64, x8610.0.14393.4046 → 10.0.26100.9711Win10 1607 → Win10 1709 (3)Host scan, Winbindex✓ 2

InternalName: stordiag, stordiag.exe · Product: Microsoft (R) Windows (R) Operating System

All 5 parsed builds · 20 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6e9632dacee2…10.0.14393.4046x86stordiag.exeWin10 1607UnsignedWinbindex
006209dfba6f…10.0.16299.15x86stordiag.exeWin10 1709UnsignedWinbindex
4348fcc1974a…10.0.15063.0x86stordiag.exeWin10 1703UnsignedWinbindex
a29bb2c2108a…10.0.26100.9711x86stordiag.exeHost scan✓
44e3ad789f92…10.0.26100.9711x64stordiag.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.