Library / Windows

subst.exe

Subst Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • Subst.Exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\subst.exe'
    - OriginalFileName: 'Subst.Exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Subst.Exe2x64, x8610.0.26100.1Host scan✓ 2

InternalName: Subst · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bd63cc290a8a…10.0.26100.1x86Subst.ExeHost scan✓
158598ed3d59…10.0.26100.1x64Subst.ExeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.