Library / Windows

systeminfo.exe

Displays system information · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 9

OriginalFilename

  • sysinfo.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: systeminfo.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\systeminfo.exe'
    - OriginalFileName: 'sysinfo.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
sysinfo.exe4x64, x8610.0.22000.653 → 10.0.26100.4202Win11 21H2Host scan, Winbindex✓ 2

InternalName: systeminfo.exe · Product: Microsoft® Windows® Operating System

All 4 parsed builds · 36 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
1675a3b805ab…10.0.22000.653x64sysinfo.exeWin11 21H2UnsignedWinbindex
0ea2b2fea540…10.0.22000.653x86sysinfo.exeWin11 21H2UnsignedWinbindex
a220a8575058…10.0.26100.4202x64sysinfo.exeHost scan✓
389d6d810ad2…10.0.26100.4202x86sysinfo.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.