Library / Windows

systempropertiesprotection.exe

System Protection Settings · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • SSystemPropertiesProtection.EXE

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: systempropertiesprotection.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\systempropertiesprotection.exe'
    - OriginalFileName: 'SSystemPropertiesProtection.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
SSystemPropertiesProtection.EXE2x64, x8610.0.26100.1Host scan✓ 2

InternalName: SystemPropertiesProtection · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
2eb9028553d9…10.0.26100.1x64SSystemPropertiesProtection.EXEHost scan✓
098e9ae9b209…10.0.26100.1x86SSystemPropertiesProtection.EXEHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.