Library / LOLBin

tar.exe

bsdtar archive tool · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBAS

OriginalFilename

  • bsdtar

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: tar.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tar.exe'
    - OriginalFileName: 'bsdtar'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
bsdtar12x64, x863.3.2.0 → 3.8.9.0Win10 1803 → Win11 26H1 (9)Host scan, Winbindex✓ 2

InternalName: bsdtar · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 16 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
d512ec29ea79…3.8.9.0x64bsdtarWin10 1809UnsignedWinbindex
b15074c812d7…3.8.9.0x64bsdtarWin10 21H2UnsignedWinbindex
a3ac62fd4cdf…3.8.9.0x64bsdtarWin11 24H2Signed (Overlay)Host scan, Winbindex✓
8edd69568287…3.8.9.0x86bsdtarWin11 23H2UnsignedWinbindex
876c6d0b5628…3.8.9.0x86bsdtarWin10 1809UnsignedWinbindex
4b72a3dada02…3.8.9.0x64bsdtarWin11 26H1Signed (Overlay)Winbindex
2c9cdeb39c63…3.8.9.0x86bsdtarWin11 24H2Signed (Overlay)Host scan, Winbindex✓
a823a5e9ae44…3.8.8.0x86bsdtarWin11 26H1Winbindex
adc2838f0d6b…3.8.1.0x86bsdtarWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
7aa6a7b0ecb7…3.8.1.0x64bsdtarWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
4489bfd47abe…3.3.2.0x86bsdtarWin10 1903, Win10 1909UnsignedWinbindex
51a4916041a2…3.3.2.0x64bsdtarWin10 1803UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.