Library / Windows

taskhostw.exe

Host Process for Windows Tasks · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 3

OriginalFilename

  • taskhostw.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\taskhostw.exe'
    - OriginalFileName: 'taskhostw.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
taskhostw.exe10x6410.0.10240.16384 → 10.0.28000.2179Win10 1507 → Win11 26H1 (11)Host scan, Winbindex✓ 1

InternalName: taskhostw.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 9 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
5b3cb177742e…10.0.28000.2179x64taskhostw.exeWin11 26H1Signed (Overlay)Winbindex
ea8d441df237…10.0.26100.8328x64taskhostw.exeWin11 24H2Signed (Overlay)Host scan, Winbindex✓
de85f29a8bc7…10.0.17763.1852x64taskhostw.exeWin10 1809Signed (Overlay)Winbindex
1876990eebc9…10.0.14393.3297x64taskhostw.exeWin10 1607Signed (Overlay)Winbindex
818c6876e102…10.0.26100.5074x64taskhostw.exeWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
a5c65c3e00bf…10.0.19041.3570x64taskhostw.exeWin10 21H2Signed (Overlay)Winbindex
a663253b39c3…10.0.17134.1098x64taskhostw.exeWin10 1803Signed (Overlay)Winbindex
0bec3128b241…10.0.18362.387x64taskhostw.exeWin10 1903, Win10 1909Signed (Overlay)Winbindex
236cac2f3764…10.0.10586.0x64taskhostw.exeWin10 1511Signed (Overlay)Winbindex
9aab619f27da…10.0.10240.16384x64taskhostw.exeWin10 1507Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.