Library / Windows

tasklist.exe

Lists the current running tasks · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 4

OriginalFilename

  • tasklist.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tasklist.exe'
    - OriginalFileName: 'tasklist.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
tasklist.exe10x64, x8610.0.10240.16384 → 10.0.26100.1Win10 1507 → Win11 25H2 (7)Host scan, Winbindex✓ 2

InternalName: tasklist.exe · Product: Microsoft® Windows® Operating System

All 10 parsed builds · 26 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
65a6b0690e2a…10.0.26100.1x86tasklist.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
62800679c556…10.0.26100.1x64tasklist.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
ecf9258bbeb3…10.0.17134.1x64tasklist.exeWin10 1803UnsignedWinbindex
cc87ad2c2a96…10.0.16299.15x86tasklist.exeWin10 1709UnsignedWinbindex
9125887b5046…10.0.14393.0x86tasklist.exeWin10 1607UnsignedWinbindex
27eddac6a2e5…10.0.14393.0x64tasklist.exeWin10 1607UnsignedWinbindex
ee668b06a7d8…10.0.10586.0x64tasklist.exeWin10 1511UnsignedWinbindex
50fbfa54bc82…10.0.10586.0x86tasklist.exeWin10 1511UnsignedWinbindex
ffeccfef135a…10.0.10240.16384x86tasklist.exeWin10 1507UnsignedWinbindex
b0df9225c292…10.0.10240.16384x64tasklist.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.