Library / Sysinternals

tcpvcon.exe

Sysinternals TcpVcon · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Tcpvcon.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as tcpvcon64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tcpvcon.exe'
    - OriginalFileName: 'Tcpvcon.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Tcpvcon.exe1x864.19.0.0Sysinternals✓ 1

InternalName: Tcpvcon.exe · Product: TcpVcon

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
37621bdac3ce…4.19.0.0x86Tcpvcon.exeTcpVconSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.