Library / Sysinternals

tcpview.exe

Sysinternals TcpView · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • TcpView.exe

Shared with other binaries

Gotchas

  • Same OriginalFilename as tcpview64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tcpview.exe'
    - OriginalFileName: 'TcpView.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TcpView.exe1x864.19.0.0Sysinternals✓ 1

InternalName: TcpView · Product: TcpView

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9775b4bbe23b…4.19.0.0x86TcpView.exeTcpViewSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.