Library / Sysinternals

testlimit.exe

Test Windows Limits · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Testlimit

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: testlimit.exe never fires.
  • Same OriginalFilename as testlimit64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\testlimit.exe'
    - OriginalFileName: 'Testlimit'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Testlimit1x865.24.0.0Sysinternals✓ 1

InternalName: Testlimit · Product: Sysinternals Testlimit

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
81ce87149a14…5.24.0.0x86TestlimitSysinternals TestlimitSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.