Library / Sysinternals

testlimit64.exe

Test Windows Limits · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 1

OriginalFilename

  • Testlimit

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: testlimit64.exe never fires.
  • Same OriginalFilename as testlimit.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\testlimit64.exe'
    - OriginalFileName: 'Testlimit'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Testlimit1x645.24.0.0Sysinternals✓ 1

InternalName: Testlimit · Product: Sysinternals Testlimit

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
f1564b3c3eee…5.24.0.0x64TestlimitSysinternals TestlimitSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.