Library / Windows

tiworker.exe

Windows Modules Installer Worker · Microsoft Corporation

WindowsParsedSigma refs: 8

OriginalFilename

  • TiWorker.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tiworker.exe'
    - OriginalFileName: 'TiWorker.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TiWorker.exe9x64, x8610.0.18362.2091 → 10.0.28000.3225Win10 1909 → Win11 26H1 (6)Winbindex

InternalName: TiWorker.exe · Product: Microsoft® Windows® Operating System

All 9 parsed builds · 13 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
396cb3d48e0a…10.0.28000.3225x64TiWorker.exeWin11 26H1Signed (Overlay)Winbindex
31fcb77c73d2…10.0.28000.3225x86TiWorker.exeWin11 26H1Winbindex
eb8a76b42b86…10.0.26100.9703x64TiWorker.exeWin11 24H2Signed (Overlay)Winbindex
304a36d42aff…10.0.26100.9703x86TiWorker.exeWin11 24H2Signed (Overlay)Winbindex
547a3c81b4fa…10.0.19041.7789x64TiWorker.exeWin10 21H2Signed (Overlay)Winbindex
e949ee85b223…10.0.22000.3250x64TiWorker.exeWin11 21H2Signed (Overlay)Winbindex
cd64281accee…10.0.18362.2091x64TiWorker.exeWin10 1909UnsignedWinbindex
9ce595c979d1…10.0.18362.2091x86TiWorker.exeWin10 1909UnsignedWinbindex
44d21b03394a…10.0.19041.1490x64TiWorker.exeWin10 20H2Signed (Overlay)Winbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.