Library / Windows

tpmtool.exe

Microsoft (R) TPM utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • tpmtool.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tpmtool.exe'
    - OriginalFileName: 'tpmtool.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
tpmtool.exe2x64, x8610.0.26100.9549Host scan✓ 2

InternalName: tpmtool · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
8229ee419f88…10.0.26100.9549x64tpmtool.exeHost scan✓
1762fbdac562…10.0.26100.9549x86tpmtool.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.