Library / Windows

tpmvscmgr.exe

TPM Virtual Smartcard Setup Utility · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • TpmVscMgr.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tpmvscmgr.exe'
    - OriginalFileName: 'TpmVscMgr.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TpmVscMgr.exe8x6410.0.10240.18818 → 10.0.28000.2804Win10 1507 → Win11 26H1 (8)Host scan, Winbindex✓ 1

InternalName: TpmVscMgr · Product: Microsoft® Windows® Operating System

All 8 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
bc0e36fbe341…10.0.28000.2804x64TpmVscMgr.exeWin11 26H1Winbindex
1dbde7f0d6db…10.0.26100.9278x64TpmVscMgr.exeWin11 24H2UnsignedHost scan, Winbindex✓
93bac4d50130…10.0.17763.1x64TpmVscMgr.exeWin10 1809UnsignedWinbindex
96e72a227d34…10.0.14393.4169x64TpmVscMgr.exeWin10 1607UnsignedWinbindex
d8e76e2d904d…10.0.26100.3323x64TpmVscMgr.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
0b9b690ca3f7…10.0.10240.18818x64TpmVscMgr.exeWin10 1507UnsignedWinbindex
4aed84b7666d…10.0.17134.1967x64TpmVscMgr.exeWin10 1803UnsignedWinbindex
1cdbe64a7b24…10.0.10586.0x64TpmVscMgr.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.