Library / Windows

trustedinstaller.exe

Windows Modules Installer · Microsoft Corporation

WindowsParsedSigma refs: 1

OriginalFilename

  • TrustedInstaller.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\trustedinstaller.exe'
    - OriginalFileName: 'TrustedInstaller.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TrustedInstaller.exe12x6410.0.10240.20680 → 10.0.28000.3086Win10 1507 → Win11 26H1 (13)Winbindex

InternalName: TrustedInstaller.exe · Product: Microsoft® Windows® Operating System

All 12 parsed builds · 7 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
09beb7a885f7…10.0.28000.3086x64TrustedInstaller.exeWin11 26H1Signed (Overlay)Winbindex
b783bfafcc8e…10.0.26100.9549x64TrustedInstaller.exeWin11 24H2Signed (Overlay)Winbindex
35af783659a9…10.0.17763.9376x64TrustedInstaller.exeWin10 1809UnsignedWinbindex
c0aed9a76034…10.0.14393.9507x64TrustedInstaller.exeWin10 1607UnsignedWinbindex
d5ba5ab7290b…10.0.10240.20680x64TrustedInstaller.exeWin10 1507UnsignedWinbindex
1889c5bc1cee…10.0.26100.5074x64TrustedInstaller.exeWin11 24H2, Win11 25H2Signed (Overlay)Winbindex
881e41e920c1…10.0.19041.1526x64TrustedInstaller.exeWin10 20H2Signed (Overlay)Winbindex
7ee90bd6a804…10.0.17134.1365x64TrustedInstaller.exeWin10 1803UnsignedWinbindex
95af07f6596a…10.0.18362.1016x64TrustedInstaller.exeWin10 1903, Win10 1909UnsignedWinbindex
f187dc7601e8…10.0.16299.1747x64TrustedInstaller.exeWin10 1709UnsignedWinbindex
9c1b8491d7d8…10.0.15063.2283x64TrustedInstaller.exeWin10 1703UnsignedWinbindex
36b95f6f2cf4…10.0.10586.0x64TrustedInstaller.exeWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.