Library / Windows

tscon.exe

Session Connection Utility · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 2

OriginalFilename

  • tscon.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tscon.exe'
    - OriginalFileName: 'tscon.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
tscon.exe6x64, x8610.0.10240.16384 → 10.0.26100.7623Win10 1507 → Win11 25H2 (5)Host scan, Winbindex✓ 1

InternalName: tscon · Product: Microsoft® Windows® Operating System

All 6 parsed builds · 17 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
b68961d57778…10.0.26100.7623x86tscon.exeWin11 24H2UnsignedWinbindex
a1f0ff0c20e5…10.0.26100.7623x64tscon.exeWin11 24H2UnsignedHost scan, Winbindex✓
4cca1e0a62f5…10.0.26100.1x64tscon.exeWin11 24H2, Win11 25H2Signed (Catalog file)Winbindex
bdc8ada1c5f9…10.0.14393.0x64tscon.exeWin10 1607UnsignedWinbindex
4723797b90e5…10.0.10586.0x64tscon.exeWin10 1511UnsignedWinbindex
2766ed1717d4…10.0.10240.16384x64tscon.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.