Library / Windows

tskill.exe

Remote Desktop Services End Process Utility · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • tskill.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tskill.exe'
    - OriginalFileName: 'tskill.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
tskill.exe1x6410.0.26100.7623Host scan✓ 1

InternalName: tskill · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
5ad6df238fae…10.0.26100.7623x64tskill.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.