Library / Windows

tstheme.exe

TSTheme Server Module · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • TSThemeS.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: tstheme.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\tstheme.exe'
    - OriginalFileName: 'TSThemeS.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TSThemeS.exe2x64, x8610.0.26100.7705Host scan✓ 2

InternalName: TSThemeS.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
ad7c418e8084…10.0.26100.7705x86TSThemeS.exeHost scan✓
3dbe5dfe3517…10.0.26100.7705x64TSThemeS.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.