Library / Windows

typeperf.exe

Command line performance monitor · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • TypePerf.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\typeperf.exe'
    - OriginalFileName: 'TypePerf.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
TypePerf.exe2x64, x8610.0.26100.9711Host scan✓ 2

InternalName: TypePerf.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6cd0d07c78f7…10.0.26100.9711x64TypePerf.exeHost scan✓
4aafbd1cf8fb…10.0.26100.9711x86TypePerf.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.