Library / Windows

uieorchestratorstub.exe

Undocked UIEOrchestrator Stub · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • UIEOrchestratorStub

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: uieorchestratorstub.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\uieorchestratorstub.exe'
    - OriginalFileName: 'UIEOrchestratorStub'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
UIEOrchestratorStub1x6410.0.26100.8115Host scan✓ 1

InternalName: UIEOrchestratorStub · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
413771957fcb…10.0.26100.8115x64UIEOrchestratorStubHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.