Library / Windows

unsecapp.exe

Sink to receive asynchronous callbacks for WMI client application · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • unsecapp.dll

Differs from file nameNames a DLL

Gotchas

  • OriginalFilename names a DLL (unsecapp.dll), not an executable. Rules expecting .exe values miss it.
  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: unsecapp.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\unsecapp.exe'
    - OriginalFileName: 'unsecapp.dll'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
unsecapp.dll8x6410.0.10240.17797 → 10.0.28000.3231Win10 1507 → Win11 26H1 (8)Host scan, Winbindex✓ 1

InternalName: unsecapp.dll · Product: Microsoft® Windows® Operating System

All 8 parsed builds · 12 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
6ebd49bf64eb…10.0.28000.3231x64unsecapp.dllWin11 26H1UnsignedWinbindex
68083e7974d0…10.0.26100.9711x64unsecapp.dllWin11 24H2UnsignedHost scan, Winbindex✓
3dbf6ff48b96…10.0.14393.9611x64unsecapp.dllWin10 1607UnsignedWinbindex
7cdf80460645…10.0.10240.17797x64unsecapp.dllWin10 1507UnsignedWinbindex
41da2bcbb07c…10.0.26100.5074x64unsecapp.dllWin11 24H2, Win11 25H2UnsignedWinbindex
fabaa4a34468…10.0.17134.1x64unsecapp.dllWin10 1803UnsignedWinbindex
5cd0dd3b1454…10.0.19041.610x64unsecapp.dllWin10 2004UnsignedWinbindex
c143819f4718…10.0.10586.0x64unsecapp.dllWin10 1511UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.