Library / Windows

updatecli.exe

Update Command Line Interface · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • updatecli

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: updatecli.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\updatecli.exe'
    - OriginalFileName: 'updatecli'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
updatecli1x6410.0.26100.9278Host scan✓ 1

InternalName: updatecli · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
3af9515f04a5…10.0.26100.9278x64updatecliHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.