Library / Windows

usoclient.exe

UsoClient · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • UsoClient

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: usoclient.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\usoclient.exe'
    - OriginalFileName: 'UsoClient'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
UsoClient1x6410.0.26100.9278Host scan✓ 1

InternalName: UsoClient · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
9a19e7d2ed5d…10.0.26100.9278x64UsoClientHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.