Library / Windows

utilman.exe

Utility Manager · Microsoft Corporation

WindowsSysmon-confirmed

OriginalFilename

  • utilman2.exe

Differs from file name

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: utilman.exe never fires.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\utilman.exe'
    - OriginalFileName: 'utilman2.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
utilman2.exe2x64, x8610.0.26100.9549Host scan✓ 2

InternalName: utilman2.exe · Product: Microsoft® Windows® Operating System

All 2 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
e9d2c4a388d2…10.0.26100.9549x64utilman2.exeHost scan✓
967bac48cda7…10.0.26100.9549x86utilman2.exeHost scan✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.