Library / Windows

vaultcmd.exe

Vault cmdline Program · Microsoft Corporation

WindowsSysmon-confirmedSigma refs: 1

OriginalFilename

  • VAULTCMD.EXE

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vaultcmd.exe'
    - OriginalFileName: 'VAULTCMD.EXE'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
VAULTCMD.EXE4x6410.0.10240.16384 → 10.0.26100.1882Win10 1507 → Win11 25H2 (5)Host scan, Winbindex✓ 1

InternalName: Credential Vault Test · Product: Microsoft® Windows® Operating System

All 4 parsed builds · 14 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
26a872c8e10c…10.0.26100.1882x64VAULTCMD.EXEWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
52be7172716a…10.0.14393.0x64VAULTCMD.EXEWin10 1607UnsignedWinbindex
4c3c8c1bf7be…10.0.10586.0x64VAULTCMD.EXEWin10 1511UnsignedWinbindex
ff14aa616eb9…10.0.10240.16384x64VAULTCMD.EXEWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.