Library / LOLBin

verclsid.exe

Extension CLSID Verification Host · Microsoft Corporation

LOLBinWindowsSysmon-confirmedLOLBASSigma refs: 2

OriginalFilename

  • verclsid.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\verclsid.exe'
    - OriginalFileName: 'verclsid.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
verclsid.exe11x64, x8610.0.10240.16384 → 10.0.28000.1896Win10 1507 → Win11 26H1 (7)Host scan, Winbindex✓ 2

InternalName: verclsid.exe · Product: Microsoft® Windows® Operating System

All 11 parsed builds · 27 Windows release groups not verifiable
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
cd351e3cae10…10.0.28000.1896x86verclsid.exeWin11 26H1UnsignedWinbindex
c269297af14f…10.0.28000.1896x64verclsid.exeWin11 26H1UnsignedWinbindex
9bc1499c7e26…10.0.26100.1x86verclsid.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
389094266638…10.0.26100.1x64verclsid.exeWin11 24H2, Win11 25H2Signed (Catalog file)Host scan, Winbindex✓
3ee33c6afffc…10.0.16299.15x64verclsid.exeWin10 1709UnsignedWinbindex
a8e467fe2427…10.0.14393.0x86verclsid.exeWin10 1607UnsignedWinbindex
9c95ef6902dc…10.0.14393.0x64verclsid.exeWin10 1607UnsignedWinbindex
a713afcfd1d7…10.0.10586.0x86verclsid.exeWin10 1511UnsignedWinbindex
45bbc795ca79…10.0.10586.0x64verclsid.exeWin10 1511UnsignedWinbindex
22e8f4573274…10.0.10240.16384x86verclsid.exeWin10 1507UnsignedWinbindex
0e45ae96cbc5…10.0.10240.16384x64verclsid.exeWin10 1507UnsignedWinbindex

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.