Library / Windows

vmconnect.exe

Virtual Machine Connection · Microsoft Corporation

WindowsParsed

OriginalFilename

  • VMConnect.exe

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vmconnect.exe'
    - OriginalFileName: 'VMConnect.exe'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
VMConnect.exe1x6410.0.26100.9711Host scan

InternalName: VMConnect.exe · Product: Microsoft® Windows® Operating System

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
192e9a95ac13…10.0.26100.9711x64VMConnect.exeHost scan

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.