Library / Sysinternals

vmmap.exe

Vmmap - process memory analyzer · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 3

OriginalFilename

  • Vmmap

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: vmmap.exe never fires.
  • Same OriginalFilename as vmmap64.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vmmap.exe'
    - OriginalFileName: 'Vmmap'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Vmmap1x863.40.0.0Sysinternals✓ 1

InternalName: Vmmap · Product: Vmmap

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
a834987f7b60…3.40.0.0x86VmmapVmmapSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.