Library / Sysinternals

vmmap64.exe

Vmmap - process memory analyzer · Sysinternals - www.sysinternals.com

SysinternalsSysmon-confirmedSigma refs: 3

OriginalFilename

  • Vmmap

Differs from file nameShared with other binaries

Gotchas

  • OriginalFilename doesn't match the file name: a rule using OriginalFileName: vmmap64.exe never fires.
  • Same OriginalFilename as vmmap.exe, so OriginalFilename alone can't tell them apart.

Query snippets

logsource:
  category: process_creation
  product: windows
detection:
  selection:
    - Image|endswith: '\vmmap64.exe'
    - OriginalFileName: 'Vmmap'
  condition: selection

process_creation logsource. Sigma string matching is case-insensitive.

Values across builds

OriginalFilenameBuildsArchFile versionWindows releasesSourceSysmon
Vmmap1x643.40.0.0Sysinternals✓ 1

InternalName: Vmmap · Product: Vmmap

All 1 parsed builds
SHA256VersionArchOriginalFilenameWindows releasesSignatureSourceSysmon
0b3731c524e6…3.40.0.0x64VmmapVmmapSysinternals✓

Winbindex builds link to the Microsoft symbol server copy that was hashed and parsed.